QAD QXtend Release Notes > Release Notes for QXI > Release Notes for Version 1.6.1
  
Release Notes for Version 1.6.1
QXI Server Version: 1.6.1
Date: June 2009
QAD Enterprise Applications Compatibility: eB SP4 through current release
QAD QXtend Documentation: Technical Reference: QAD QXtend (78-0691C) and Installation Guide: QAD QXtend (78-0692B)
Important: If you are using QAD 2009 EE or SE, use Qxtend version 1.6.1.
Fixes
1 When installing QAD QXtend using the console mode and a local repository, and the file specified is not found, the system now displays a correct warning. Previously, in this situation a message displayed stating that there was nothing to install on the host.
2 In the previous version, double-byte characters in a QDoc caused the system to return an error in certain situations; for example, if they were used in a filter in a QDoc for the Query Service.
3 The handling of spacebar processing has been enhanced. Previously, when dealing with certain types of QDocs, the slow handling of spacebar processing adversely affected the performance of QXI.
4 Previously, when QXI processed QDocs to QAD Enterprise Application with a non-ISO 8859 code page, if the QDoc used special characters (including double-byte characters) and a preprocessor was defined for the QDoc, the system gave error EventException019. QDocs in this situation can now be processed without error.
Known Issues
1 In an AIX environment, if you use the 1.0 syntax specification with your QDocs, the post-processing program may return an error even though processing was successful. You can avoid this situation either by using the QDoc 1.1 specification instead, or by increasing the Message Timeout value for the QXI connection pool.
2 When scopetransaction is set to false and a QDoc contains multiple requests for native APIs, if an error occurs in one request, subsequent requests are not processed.