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Chapter 1 Introduction

This chapter includes:

Section 1: Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

Section 2: User Groups  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

Section 3: Documentation Conventions . . . . . . . . . . . . . . . . . . . 7

Section 4: Acronyms and Abbreviations. . . . . . . . . . . . . . . . . . . 8

Section 5: Software License; Intellectual Property . . . . . . . . . . . 9

Section 7: Revision History. . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

Section 1: Overview

The Inventory Management (IM) Tool is an add-on application of the 
Demand Management Engine (DME). This guide will teach you how to 
use the Inventory Management Tool so you can manage your inventory 
efficiently to decrease unnecessary expenses and increase ROI. 
Below is a high-level depiction of QAD Demand Management.
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Chapter 1
1-1: Inventory Management Tool Highlights

Maximizes your profitability margin by gauging inventory 
levels and expenses.

Manages inventory to meet forecasted demands.

Establishes safety stock levels to meet unexpected 
demands.

Maintains service levels.

1-2: Logging In

You can access the IM Tool by logging into the DME application. You 
must have a DME username and password to use the IM Tool and do 
not need a separate username and password. Please contact your 
Rev 0 6



Chapter 1
System Administrator if you forgot or do not have a username and 
password.

You can change your password in the Base Unit when you log in.

Note: Usernames and passwords are case sensitive.

1-3: Logging Out

If you would like to log out of the application, in the DME Viewer, click 
on File > Exit. Make sure you click Save to prevent losing any content 
you added.

Section 2: User Groups

User groups and privileges are dependent upon permissions granted 
by the System Administrator. The System Administrator configures 
the Inventory Management Tool for individual users or user groups. 
Please contact your System Administrator if you have questions 
about your user privileges.

Section 3: Documentation Conventions

3-1: Text 

The following table lists text conventions in this user guide.

Table 1-1: Default Username and Password

Username fxadmin

Password fxadmin
Rev 0 7
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3-2: Screen Captures

The example screens in this guide may not represent what you see 
on your monitor; use them only as guidelines.

Section 4: Acronyms and Abbreviations

Table 1-2: Text Convention Descriptions

Convention Description

Text represented as a screen display. This typeface represents displays that appear on your 
terminal screen, for example:

lom>

Text represented as menu or sub-menu 
names.

This typeface represents all menu and sub-menu 
names within procedures, for example:
On the File menu, click New.

Table 1-3: Acronyms and Abbreviations used in this Manual

Term Definition

DME Demand Management Engine

IM Tool Inventory Management Tool

DRP Demand Replenishment Planning

BOM Bill of Materials

PO Purchase Order

UOM Unit of Measurement
Rev 0 8
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Section 5: Software License; Intellectual Property

5-1: Preamble

Any software provided to the customer is subject to the specific 
license terms and conditions of the applicable agreement, or shrink-
wrap, or click-wrap license.

In the event of any conflict between those specific terms described 
below, the specific terms will supersede and prevail.

QAD Inc. agrees to those terms and are provided as follows.

5-2: License Grant

QAD Inc. grants to Customer a limited non-transferable 
license to use the Licensed Software subject to the limitations 
imposed under this Agreement and to the following:

The Permitted Users shall use the Licensed Software only on the 
equipment located at the Site. Customer must obtain a 
supplementary license from QAD Inc. (which QAD Inc. may or may 
not grant, at its option) before using the Licensed Software.

Customer may make one copy of the Licensed Software in machine-
readable form solely for backup purposes and shall reproduce on any 
such copy the copyright notice and any other proprietary labeling of 
QAD Inc. that were on the original copy.

Customer shall comply with all restrictions on the use of Licensed 
Software that Customer is subject to as a licensee or sublicensee of 
QAD Inc. under the terms of licenses or other agreements 
or arrangements by QAD Inc. with third parties.

5-3: Restrictions

Except as necessary for Customer to exercise its express rights 
hereunder, Customer may not itself or allow any third party to (i) make 
copies of the Licensed Software, (ii) distribute the Licensed Software 
Rev 0 9



Chapter 1
to others, (iii) electronically transfer the Licensed Software from one 
computer to another over a network, or (iv) decompile, reverse 
engineer, disassemble, or otherwise reduce the Licensed Software to 
a human perceivable form. CUSTOMER MAY NOT MODIFY, ADAPT, 
TRANSLATE, RENT, LEASE, LOAN, RESELL FOR PROFIT, 
DISTRIBUTE, NETWORK, OR CREATE DERIVATIVE WORKS 
BASED UPON THE LICENSED SOFTWARE OR ANY PART 
THEREOF.

5-4: Ownership of Media

The media on which the Licensed Software is recorded or fixed is 
Customer's property. If Customer receives Licensed Software 
hereunder that renders Licensed Software that Customer has 
previously received redundant, Customer will return the redundant 
Licensed Software to QAD Inc. or certify in writing that all 
copies of such Licensed Software have been erased.
Rev 0 10
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Section 7: Revision History

Rev Date Author Reason For Changes

0 9/2006 HDB Initial release for Inventory Management 
Tool 3.0
Rev 0 11



Chapter 2 Using the Inventory Management Tool

This chapter includes:

Section 1: Overview  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Section 2: IM Tool at a Glance  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Section 3: Customize DRP . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

Section 4: RUN DRP. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

Section 5: Run DRP in Level. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

Section 6: Input Daily Detail  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Section 7: Input BOM Information . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23

Section 8: View Daily Output. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

Section 9: View Action Message. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

Section 10: Input PO UOM . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Section 11: PO Launcher  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

Section 12: Safety Stock . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39

Section 1: Overview

The Inventory Management Tool enables you to track your inventory 
based upon data and calculations that your System Administrator has 
configured. This chapter details the IM Tool’s features and how to access 
them.

Section 2: IM Tool at a Glance

The depiction below details the features available in the IM Tool. You can 
use all the features listed except for Admin Tool and Safety Stock > 
Settings; these features are for System Administrators only.
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Chapter 2
The table below describes what each feature means. Each feature is 
discussed in more detail later in this chapter.

Table 2-1: Inventory Management Tool Features

Feature Description

Admin Tool Used to create and configure entities. Only the System 
Administrator has access to this feature.

Run DRP Calculate recommended order based on inventory and 
other settings. Can be run on a series or scenario level.

Run DRP in 
Level

Calculate orders on a scenario level when there is a 
hierarchy applied to the scenario. It can be calculated 
in single or multiple levels. Single level runs on a 
specific level and pushes the results to a higher level. 
Multiple level runs the DRP from a lower level to the 
upper level and then uses that output as a base for 
another DRP analysis.

Input Daily Detail Review manual input. Can be used for what if analysis.

Input BOM 
Information

Adds Bill of Materials information to calculate the DRP 
for components.
Rev 0 13



Chapter 2
You can retrieve these features by either clicking on Inventory on the 
toolbar. Alternatively, you can customize your toolbar to display these 
features.

1. Click on the icon at the top right of the Viewer window.

2. Select Add or Remove Buttons.

3. Hover your mouse over DRP. 

View Daily DRP 
Output

View the Daily DRP Output.

View Action 
Message

View the DRP Action Messages.

Input PO UOM Input Unit of Measurement information for Purchase 
Orders, particularly for the budget limit functionality.

PO Launcher Use to view, schedule and release Purchase Orders.

Safety Stock Provides data for safety stock levels and enables you 
to determine safety stock levels by simulating various 
criteria. The simulator provides detailed what if 
analyses. The calculator shows different safety stock 
levels in batch mode. Safety Stock settings are 
configured by the System Administrator only.

Table 2-1: Inventory Management Tool Features

Feature Description
Rev 0 14



Chapter 2
The IM Tool features are listed. 

4. Select those you want on your toolbar. You can also click on Reset 
Toolbar to revert to the default settings.

Section 3: Customize DRP

You can customize the DRP to include specific fields when calculating 
data for a Scenario.

1. Log into the Viewer and open a Scenario.

2. Click on the Demand Data tab and right-click in the columned area.

3. Click on the Customize DRP window.
Rev 0 15



Chapter 2
The General Selection window displays.

4. Select the fields from the Available list and click on the right arrow to 
move them to the Selected list. You can add multiple fields by 
pressing CTRL and the fields listed. You can also remove fields by 
clicking on the fields in the Selected list and clicking on the left arrow 
to put them in the Available list.

5. Click OK when finished.

The columns in Demand Data view are populated with the newly 
selected fields.

Section 4: RUN DRP

The table below describes what is needed to calculate the DRP. 

Information Description

Replenishment 
Type

Determines which type of calculation is used to 
calculate recommended order.
Rev 0 16
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1. Go to Inventory > Run DRP.

The Run DRP window displays.

2. You can select to run the entire Scenario or a series. Click Run.

Demand Type Determines which type of calculation is used to 
anticipate demand.

DRP Start Date The first period on which DRP calculations will begin.

DRP End Date The last period on which DRP calculations will execute.

Safety Stock Determines which type of calculation is used to 
determine when stock needs to be replenished.

Information Description
Rev 0 17



Chapter 2
The results for a basic DRP calculation display.

The Forecast value represents the demand, which, in the above example, 
is 188 units for the first period. The Beginning Inventory for the first period 
is the initial stock on hand. For subsequent periods, the stock on hand is 
the End Inventory from the previous period. The Ending Inventory is the 
Beginning Inventory minus the Demand plus the Recommended Order 
Arrival. 

Since the Replenishment Target is only one and a half periods, the 
system will not recommend an order until one and a half months before 
the inventory will fall below the pre-assigned levels.

The Recommended Order Release occurs in August and the order 
arrives in September because there is a one month lead time for that 
Rev 0 18
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specific order. If another calculation were run with a two month lead time, 
the DRP would recommend the order in July rather than August.

The depiction below details the Graph View for min/max Replenishment 
Type.

Section 5: Run DRP in Level

You can run the DRP in two types of levels - single and multiple. If you 
have a hierarchy applied, you can use Location Routing Demands. 
Instead of using the forecast of the upper level of the hierarchy, you use 
the demands from the lower level. You use the recommended orders of 
the lower levels as demand to be filled in the upper level. In the multiple 
level, that demand is used as the base of the next level of calculation.

5-1: Single Level

You can set single levels in the DRP. Single Level enables you to sum up 
the Opinion Line, move it to the upper level and run the Recommended 
Rev 0 19
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Order Opinion Line. Rather than running the Location Routing Demand 
Opinion Line at multiple levels, you can run it once.

1. Go to Inventory > Run DRP in Level > Single Level.

The Single Line window displays.

2. In the Opinion Lines Need to Sum Up area, you can change which 
Opinion Lines that will be summed up by clicking on Change.

3. In the Run Option area, select Run Whole Tree, Scenario (select the 
scenario from the drop down text box) or Selected Series.

4. Click Run.

5-2: Multiple Level

You can set multiple levels in the DRP.
Rev 0 20
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1. Go to Inventory > Run DRP in Level > Multiple Level.

The Multiple Line window displays.

2. In the Recommended Order Release Opinion Line drop down box, 
select from the list where the Recommended Order Releases should 
be arriving from. 

3. In the Location Routing Demand Opinion Line drop down box, select 
from the list where the Recommended Orders should to copied to in 
the upper level of the hierarchy. Your selection should be set up as 
the Dependent Demand for the DRP in the upper level.

4. Click Run.

Section 6: Input Daily Detail

The Input Daily Detail feature is used to input daily figures, view and 
review daily input, and as a ‘what if’ analysis.

You can calculate the Daily DRP Input within the DRP. To view the Daily 
Input in the DRP:

1. Go to Inventory > Input Daily Detail.
Rev 0 21
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The Input Daily Detail Information window displays.

2. From the Date Range tab, in the Date Range area, provide the dates 
you want the DRP BOM Input to be calculated within.

3. Click Save to save your settings.

4. Click View.

The Daily DRP Input calculations display.

Note: You can click on the columns’ headings to arrange the calculations in 
decremental or incremental order.
Rev 0 22
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Note: You can drag a heading to the grey area to display only that column. 
You can also add more columns to group the columns in hierarchal 
order.

5. From the Date Range tab, in the Date Range area, provide the dates 
you want the DRP to calculated within.

6. Click Save to save your settings or Cancel to close the Daily DRP 
Input window.

7. Click View.

8. To change the date range, hover your mouse over the date in the 
Date column and click on the arrow to change the date.

9. To add a row to the DRP Input calculations, click on the  icon. 

To delete a row, click on the  icon.

Section 7: Input BOM Information

You can calculate the BOM information within the DRP. To access the 
Input BOM Information feature:

1. Go to Inventory > Input BOM Information.
Rev 0 23



Chapter 2
The Input DRP BOM window displays.

2. From the Data Range tab, in the Item Range area, select if you want 
to calculate the entire Scenario or just the Selected Series.

3. Click Save to save your settings.

4. Click View.
Rev 0 24
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The Input DRP BOM calculations display.

The Item column lists the items (i.e., components, pieces) that make 
up the Parent. For example, an item could be a wheel for a bicycle 
(Parent). The Factor column lists how many items are needed for one 
Parent order.

Note: You can click on the columns’ headings to arrange the calculations in 
decremental or incremental order.

Note: You can drag a heading to the grey area to display only that column. 
You can also add more columns to group the columns in hierarchal 
order.
Rev 0 25
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5. From the Date Range tab, in the Date Range area, provide the dates 
you want the Input DRP BOM to calculated within.

6. Check the Provide Drop Down for Input checkbox to list all linked 
fields (i.e., by Description or SKU numbers).

7. Click Save to save your settings or Cancel to close the Input DRP 
BOM window.

8. Click View.

9. To change the date range, hover your mouse over the date in the 
Date column and click on the arrow to change the date.

10. To add a row to the BOM Input calculations, click on the  icon. 

To delete a row, click on the  icon.

Section 8: View Daily Output

The View Daily Output feature is used to view the Daily DRP Output. You 
must first run the DRP calculations. To view the Daily View in the DRP:

1. Go to Inventory > View Daily Output.
Rev 0 26
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The View Daily Output window displays.

Note: You must have Daily Output enables to see Orders in the Daily View.

2. From the Data Range tab, in the Item Range area, select if you want 
to calculate the entire Scenario or just the Selected Series.

3. Check the Only Show Non-Zero Value if you want to view non-zero 
values only.

4. Click View.

The DRP Output calculations display.
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Note: You can click on the columns’ headings to arrange the calculations in 
decremental or incremental order.

Note: You can drag a heading to the grey area to display only that column. 
You can also add more columns to group the columns in hierarchal 
order.

5. From the Date Range tab, in the Date Range area, provide the dates 
you want the DRP to calculated within.

6. Click View.

7. To change the date range, hover your mouse over the date in the 
Date column and click on the arrow to change the date.

8. Click Cancel to close the Daily View window.

Section 9: View Action Message

The Action Message View feature enables users to review the actions 
sent by the DRP. Thus, the user has the opportunity to address possible 
issues with orders before they become problems. It is also used to view 
the DRP Action Messages. You can calculate the DRP Action Messages 
within the DRP. To view the View Action Message in the DRP:

1. Go to Inventory > View Action Message.
Rev 0 28
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The View Action Message window displays.

2. From the Data Range tab, in the Item Range area, select if you want 
to calculate the entire Scenario or just the Selected Series.

3. From the Exception drop down box, select which Action Message you 
want displayed. The table below details each exception.

Action Message Description

All Shows all Action Messages.

Delay Shows Orders that the IM Tool calculates a 
recommended delay.
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4. Click View.

The DRP Action Message calculations display. 

Note: You can click on the columns’ headings to arrange the calculations in 
decremental or incremental order.

Note: You can drag a heading to the grey area to display only that column. 
You can also add more columns to group the columns in hierarchal 
order.

5. From the Date Range tab, in the Date Range area, provide the dates 
you want the DRP to calculated within.

6. Click View.

7. Click Cancel to close the Daily Action Message window.

Section 10: Input PO UOM

The Input PO UOM feature is used to input Unit of Measurement 
information for Purchase Orders; this is particularly important for the 

Expedite Shows Orders that the IM Tool calculates a need to 
move forward.

Cancel Shows orders that the IM Tool calculates a need to 
cancel.

Delay to Cancel Shows orders that the IM Tool calculates a long delay 
and, therefore, may need to be cancelled.

Critical 
Understock

Shows orders that the IM Tool calculates that stock will 
be depleted before the end of the lead time for that 
product.

Understock Shows orders that the IM Tool calculates that stock will 
be depleted at the end of the lead time for that product.

Action Message Description
Rev 0 30
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budget limit functionality. You can calculate the PO UOM Input within the 
DRP. To view the PO UOM Input in the DRP:

1. Go to Inventory > Input PO UOM.

The PO UOM constraints display.

2. From the Data Range tab, in the Item Range area, select if you want 
to calculate the entire Scenario or just the Selected Series.

3. Click Save to save your settings.

4. Click View.

The PU UPOM calculations display.
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Note: You can click on the columns’ headings to arrange the calculations in 
decremental or incremental order.

Note: You can drag a heading to the grey area to display only that column. 
You can also add more columns to group the columns in hierarchal 
order.

5. From the Date Range tab, in the Date Range area, provide the dates 
you want the PO UOM to calculated within.

6. Click Save to save your settings or Cancel to close the PO UOM Input 
window.

7. Click View.

8. To change the date range, hover your mouse over the date in the 
Date column and click on the arrow to change the date.

9. To add a row to the PO UOM Input calculations, click on the  

icon. To delete a row, click on the  icon.

Section 11: PO Launcher

The PO Launcher feature is used to make Purchase Orders, schedule 
Purchase Orders, and view Purchase Orders that have been made. 

To view the PO Launcher in the DRP:

1. Go to Inventory > PO Launcher.
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The PO Launcher window displays with the Launch tab active.

11-1: Launch tab

To get all Recommended Orders from the DRP Output (i.e., View Daily 
Output). This tab is used to find and filter all the recommended orders 
generated by the DRP calculations or entered by the user in the Input 
Daily Detail.

The following table details the features from the Launch tab.

Feature Description

Search List Displays all the fields defined to filter items.
Rev 0 33
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1. In the Search List area, select the Item you are searching. If you 
configured the PO Launcher to search for SKUs, the list of SKUs 
available is listed. 

2. Select the location of the items in the Location drop down.

3. Select the Start Date and End Dates for the searching criteria.

Alternatively, select the month and year in the Req. Period drop down 
or the specific date in the ReqDate drop down.

4. Click the  icon.

Date Filters Displays open Orders by date of recommended 
release. Only dates between the Start Date and End 
Date are displayed.

Budget Limit Displays all the fields defined in the PO Budget tab.

Feature Description
Rev 0 34
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The list of items search displays in the SKU List area.

The table below details the additional features/icons from the Launch tab.

Feature Description

Optimize Relates to Budget Limit. You can choose Opportunity 
or Speed.

Opportunity - Searches best deals for PO from all 
possible combinations.
Speed - Quick search that stops once it finds the 
best deal from simple combinations.

Show/Hide 
Description Field

You can show or hide the Description column.
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11-2: Schedule tab

The Schedule area in the PO Launcher is used to automate schedules for 
Purchase Orders.

Release Releases the PO. The IM Tool recalculates the DRP 
and, thereafter, you can view your order in Committed 
Order Arrival (Com Ord Arr) and the View tab.

Budget Limit You can narrow your search criteria based upon the 
configurations you created. The example above 
displays Money or Truck search criteria.

Show Unit 
Constraint

Used to ensure a PO does not exceed a pre-defined 
limit.

Refresh Updates the calculations after changes have been 
made.

Feature Description
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The depiction below is the Schedule feature.

The list of Purchase Orders that are scheduled for release are listed.

To add a PO to your schedule:

1. In the Search List area, select the Item you are searching. If you 
configured the PO Launcher to search for SKUs, the list of SKUs 
available is listed. 

2. Select the location of the items in the Location drop down.

3. Select either a monthly or weekly search by clicking on the By Month 
or By Week criteria. 

Thereafter, select which month you would like to search if you chose 
monthly or the day of the week if you chose weekly.

4. Click the  icon.
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The newly created schedule is listed at the bottom of the list of 
schedules. 

5. Alternatively, to delete a schedule from the list, highlight the PO in the 

Scheduled POs area and click on the  icon.

11-3: View tab

The View area of the PO Launcher is used to view Purchase Orders that 
have been released.

The depiction below is the View feature.

To view the Purchase Orders that have been made:
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1. In the Search List area, select the Item you want to search for. If you 
configured the PO Launcher to search for SKUs, the list of SKUs 
available is listed. 

2. Select the location of the items in the Location drop down.

3. Click on the  icon to list all the Purchase 
Orders.

The list of Purchase Orders refreshes and lists all the current 
Purchase Orders.

Section 12: Safety Stock

The IM Tool has a Safety Stock Simulator and a Safety Stock Calculator, 
which allow users to experiment with different levels of Safety Stock to 
determine both cost and service level of inventory. 

12-1: Simulator

The Safety Stock Simulator provides a graphical representation of the 
Service Levels of Safety Stock quantities. It allows the user to determine 
the impact of different safety stock levels.

Note: The Safety Stock Settings is for System Administrators only.

To access the Safety Stock Simulator:

1. Go to Inventory > Safety Stock > Simulator.
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The Safety Stock Simulator window displays.

You can vary the amount of Safety Stock, the Service Level or the 
Coverage Level and recalculate the Safety Stock for a given period. 
You can also enter a cost factor, enabling you to set no cost or fixed 
cost for a particular series attribute that you would like to use as a 
cost or time phase cost. If you have an Opinion Line that you would 
like to use as cost, the system multiplies the individual demands by 
that factor. 

The IM Tool calculates the number of periods based on the demand 
for the simulated period. The window above shows a 89.50% Service 
Level, which means that there is a 89.5% chance of having enough 
inventory on hand to meet demand.

2. Click Save to save the Scenario. The Scenario is saved to the 
Opinion Line that you selected.
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12-2: Calculator

The calculator allows you to view different Safety Stock levels in Batch 
Mode. To access the Safety Stock Calculator:

1. Go to Inventory > Safety Stock > Calculator.

The Safety Stock Calculator window displays.
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2. In Step 1 area of the window, select either the Select in Series or 
Scenario. 

3. Choose the Scenario you want to view.

4. Click Show Data.

The data for that scenario displays.
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5. In Step 2 area of the window, select the Safety Stock Type Option you 
want to view. The table below details each option.

Note: Depending upon how your System Administrator configured the 
entity, you may be unable to view certain Safety Stock Type Options 
other than the default settings.

6. Depending upon which option you selected, the tabs to the right of the 
Safety Stock Options selections are activated. For example, if you 
selected Statistics Type, the Statistics tab is activated.

7. Select the Safety Stock Option you want to use. Make any changes 
needed and click on Calculate.

The data is then updated based upon the criteria you chose.

8. To view a different set of calculations, select different options in Step 
1 and Step 2 in the Safety Stock Calculator window and click OK.

The calculations depict the Safety Stock Type, Safety Stock Lead Time, 
Target Service Level, and Actual Service Level for each period in the 
columns. The table below details each feature.

Option Description

Use Settings as 
Shown

The existing settings are used.

All Series use 
“Statistics” Type

Statistic Safety Stocks are used.

All Series use 
“Period 
Coverage” Type

Period Coverage Safety Stocks are used.

All Series use 
“User Input” 
Type

Internal Safety Stocks are used.

Feature Description

Safety Stock 
Type

Statistics, Coverage or Internal.
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Note: If you want to have a backup copy of Safety Stock calculations, check 
the Reload from Database check box at the top-right of the window.

9. Click OK to close the window.

Safety Stock 
Lead Time

Number of periods inventory needs to cover.

Target Service 
Level

Percentage goal for how likely Safety Stock will be able 
to cover demand.

Actual Service 
Level

Calculated percentage for how likely Safety Stock will 
be able to cover demand.

Feature Description
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