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Change Summary

The following table summarizes significant differences between this document and the version 
released with QAD Planning Portal 5.5.

Date/Version  Description Reference

March 2012/version 6.1 Major changes throughout --
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Overview

This chapter details the installation procedure for the Planning Portal application. Please follow the 
instructions carefully to ensure a successful installation.

The following chart shows the architecture of the Planning Portal and the software requirements.

Requirements

As mentioned above, the installation process for the Planning Portal is automated. However, there 
are certain hardware and software requirements necessary to ensure the application installs 
successfully.

Hardware

The list below details the required hardware to install the Planning Portal.

Table 1.1  Database Server Hardware Requirements

Hardware Minimum Recommended

CPU Dual 850 MHz Pentium III Quad 2.2 GHz Xeon Processors

RAM 8GB RAM 8 GB RAM

Hard Disk Ultra SCSI- II, RAID 5 hard drive controller

One to three 36GB Hard Drives

Ultra SCSI - II internal and additional RAID 5 
Hard Drive controller.

Mirrored volume for system and temp files (36GB 
each drive).

Two RAID 5 Data volumes with three drives 
minimum (36 GB each drive).

Table 1.2  Web Server Hardware Requirements

Hardware Minimum Recommended

CPU Dual 850 MHz Pentium III Quad 2.2 GHz Xeon Processors

RAM 8GB RAM 16 GB RAM

Hard Disk Ultra SCSI - II, RAID 5 hard drive controller. Ultra SCSI - II internal and additional RAID 5 
Hard Drive controller.
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Note   The PP Admin Tool has to run on the same computer where the Planning Portal was 
installed. Since the Admin Tool changes the settings defined in web.config file (Planning Portal 
configuration file), this needs to be executed locally in the Web Server where the PP is 
installed.

Table 1.3  Client Machine Hardware Requirements

Hardware Minimum Recommended

CPU Pentium III - 500 MB Pentium IV- 2.0 GB Pentium M - 1.2 GHZ

RAM 1 GB 2 GB

Hard Disk 200 MB 500 MB

Software Media

All the software mentioned below needs to be installed correctly and functioning properly before 
you attempt to install the Planning Portal.

Database Server

• Windows 2003 or 2008 Server. The most current Service Packs are highly recommended.

• SQL Server 2005 or 2008. The most current service packs are highly recommended). If SQL 
Server is not installed, the Demand Management Engine provides the option to install SQL 
Express Edition instead.

Web Server

• Windows Server 2003 / 2008. The most current Service Packs are highly recommended.

• Internet Information Services (IIS) 6.0 / 6.5 / 7.0 / 7.5

• .NET Framework 3.5 (with SP1)

• .NET Framework 2.0 (with SP2)

• ADO 2.8

• Installer 3.5 (SP1)

• Microsoft Excel Primary Interop Assembly (PIA). Must match Office version.

Client Machine

• Windows XP / Windows Vista / Windows 7

• Office 2003 / 2007 / 2010 (To support export to Excel)

• Internet Explorer 7 / 8 / 9

Note   You can download and install.NET 2.0, ADO 2.8, and Installer 3.1 from 
www.microsoft.com.
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Prerequisites

The list below details the prerequisites for the installation.

• IIS 6.0 / 6.5 / 7.0 / 7.5

• Windows Installer 3.5 SP1

• Microsoft .NET Framework 3.5 SP1

• Microsoft .NET Framework 2.0 SP2

• Internet Explorer 7 / 8 / 9 (with compatibility mode enabled - for more information, see 
“Compatibility Mode (Required)” on page 32)

Note   If IIS is not on the Web Server, but .NET Framework 2.0 already is, you must run the 
process in Section 7-2: “Registering .NET Framework (Optional)” on page 19.

Microsoft .NET Framework 2.0 (Service Pack 1)

You must verify that ASP.NET 2.0 can run on the web server; this can be done by finding it in web 
server extensions.

1 Go to My Computer > Program Files > Windows > Internet Information Services (IIS) 
Manager.

2 Click on “Web Service Extensions” under your computer.

The Web Service Extensions window displays to the right as shown below.

3 Right-click on “ASP .NET v2.0 50727” and select “Allow in the window”.

4 Close the window when finished.

Configure a JSE as MIME Type

To configure a JSE as a MIME Type:

1 Go to My Computer > Program Files > Windows > Internet Information Services (IIS) 
Manager.

2 Right-click on the SERVERNAME (local computer) node.
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3 Click on Properties.

4 Click the MIME Types button.

5 Click New to add entry.

6 Enter “.jse” in the extension textbox (no quotes).

7 Enter “application/x-javascript”.

8 Click OK to close the dialog box.

9 Click OK to close the Property dialog box.

10 Right-click on the SERVERNAME (local computer).

11 Select All Tasks.

12 Click Restart IIS… to apply the changes.

Client Computers

Client computers require the following software media to ensure the Planning Portal is used 
optimally:

• Microsoft Internet Explorer 7 / 8 / 9

• Macromedia Flash plug-in for Internet Explorer.

Other Prerequisites

To upgrade the PP database you need the system administrator (sa) account password for the SQL 
instance being upgraded.

Uninstalling the Planning Portal

This section describes how to uninstall the Planning Portal. This process is necessary before installing a new 
version of the Planning Portal.

Note   If you plan on upgrading PP and keeping all your existing configurations, you need to 
make sure to save the following files:

a. web.config

b. CustomSettings.xml 

c. Locale.xml

Note   After Version 5.5 the Locale.xml file was re-named to Localization.xml. If you are 
using the Upgrade Tool it will take care of migrating to the new file name.
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These files are located in the folder where PP was installed. The default locations are:

a. c:\inetpub\wwwroot\PlanningPortal\web.config

b. c:\inetpub\wwwroot\PlanningPortal\CustomSettings\
CustomSettingsSchema.xml

c. c:\inetpub\wwwroot\PlanningPortal\CustomSettings\
Localization.xml

Note   This version of the PP can upgrade configurations files from version 5.5 and higher 
only. If you are moving to this version from any version before 5.5, backup the current data 
and settings first. For more information see “Installing the Planning Portal” on page 8

1 To remove the current version of the Planning Portal, go to:

Start > Control Panel > Add/Remove Programs.

The Add/Remove Programs window is displayed.

2 Select “QAD - Planning Portal.”.

3 Click Uninstall. You will be prompted to confirm the uninstall request.

4 Click Yes.

5 Click Yes.

6 Install the latest version of the Planning Portal as detailed in “Installing the Planning Portal” on 
page 8

Note   After uninstalling any previous versions of the PP you will need to manually remove 
the PP folder (C:\Inetpub\wwwroot\PlanningPortal by default) since some files may still 
remain in the folder.

Note   After uninstalling any previous versions of the PP you will need to manually remove 
the PP temp files folder: C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary 
ASP.NET Files\planningportal by default. Change “Framework” to “Framework64” on 64 
bit systems.

Note   After uninstalling any previous versions of the PP you will need to clear your browser’s 
temporary files.

DME Admin Settings for Planning Portal

You must edit the Living Master scenario that is to be used with the Planning Portal.

1 Log into the DME Admin Tool.

2 Click the Scenarios button in the toolbar.
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The Scenario Manager window displays.

3 Select the scenario to use from the Scenario List in the left panel.

The Scenario details display in the Scenario Editor panel at the right.

4 In the Properties panel of the Scenario Editor, click the “User Field Settings” tab.

5 Enter or select “WebForm” in User Field 2. This makes the scenario available in the Planning 
Portal. Only scenarios that have this property set and are Living Master scenarios will be 
available in the Planning Portal.

6 Click Save.

7 Next you must go into the Scenario Permissions window by clicking on the “Permissions” 
button  and assign the scenario to any user that you need to have access to the 
scenario through the planning portal.

8 Click Save on the Scenario Permissions window.
                                                 



8     Installation Guide — QAD Planning Portal
9 Close the Scenario Manager.

Installing the Planning Portal

This section details how to install the Planning Portal.

Installation Options/Architecture

There are two different ways to install the Planning Portal. Depending upon your network 
configuration, you can install the application on either one server or two.

The illustration below depicts the two ways to install.

Prerequisites

The list below details the prerequisites prior to beginning the installation.

• Demand Management Engine installed.

• A Living Master Scenario configured as described in Section 5 above (or a default DTL Scenario).
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Installation Process

1 Get the installation files for the Planning Portal. If the file you have is a .zip or .rar file make 
sure to un-compress the files before installing them.

2 Double-click the PPSetup.exe file.

3 The JGS App Requisites Validator window will process your system to check if some of the 
necessary components for the PP are installed and correctly configured. If all the requisites 
where found and configured correctly the window will look like this:

4 Click Continue.

The Planning Portal Installation window displays.

5 Click Next.
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The Planning Portal License Agreement window displays.

6 After reading the agreement, select the “I accept the terms in the license agreement” radio 
button and click Next. Otherwise, click Cancel to quit.

The Customer Information window is displayed

7 Enter your User Name and Organization name in the respective fields and click Next.

The Setup Type window is displayed:
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8 There are two types of installations for the Planning Portal, the “Complete” option will install 
all the available components and the “Custom” option allows you to select which components to 
install. The following table describes the different components that can be installed for the 
Planning Portal:

Table 1.4  Planning Portal Components

Component Description

Database Administration 
Tool

This component updates the Planning Portal Database to the 
latest version as well as installing necessary components for 
the DB Server.

Planning Portal This component contains the actual files to install the 
Planning Portal in a web server.

You will probably want to use the Complete option when your Web Server and SQL Server are on 
the same computer, and the Custom option when your SQL Server and Web Server are different 
servers, this way you will be able to only install the Planning Portal component in the Web Server 
and only the Database Administration tool on the SQL Server.

If you run a Custom install, you will be prompted with the following screen to choose the 
components to install:

9 Click Next to continue the install. If you select the Planning Portal component or a Complete 
install continue to Step 10; if you only selected to install the Database Administration Tool, 
skip to Step 12.
                                                 



12     Installation Guide — QAD Planning Portal
10 The following screen is the Installation Address. Here you can choose certain options for the 
Planning Portal component installation:

These settings are related to IIS; you are able to setup the Site under which to install the 
Planning Portal, the name of the Virtual Directory and the Application Pool the Planning 
Portal will be associated with. Unless you are familiar with these settings use the defaults and 
click Next.

11 The Ready to Install screen will be displayed, if you are sure your settings are correct just click 
Install to continue.
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12 If the Database Administration Tool component was selected you will be prompted with the 
following screen:

In this screen you must provide the information to be used to connect to the database including 
Server Name, Database Name and SQL User account and Password to connect to the 
database.

When performing an upgrade on the database the system administrator account (“sa”) should 
be used always. For regular operations for the Planning Portal you can change the SQL 
account used in the PP Admin Tool.

The Excel file path is the path to a file used for the promotions feature, If you are not planning 
on using this feature the default value is fine.

• Month-Week.xls - if your Promotions are run weekly.

• Week-Day.xls - if your Promotions are run daily. 

The Excel file path will default to:

C:\Program Files\QAD\QAD - Planning Portal Database Upgrade

After all the database related information is input you can test your connection by clicking the 
Test Connection button. If the test is successful, click the Upgrade Database button to begin 
the process.
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The following window displays while running the upgrade.

When the process is completed you will see the following message.

13 The Internationalization Configuration Wizard window will appear. If you are not converting 
the database to support double-byte characters or don’t want to execute the changes, press the 
Close button.

If you are upgrading the database to support double-byte characters, select the link to run the 
internationalization upgrade tool.

14 Click OK.
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If you chose to install the Planning Portal component or a Complete Installation option, the 
Planning Portal Setup window displays. You can configure the Administration Utility now or at 
a later time.

15 Click OK to launch the Administration Utility, the PP Admin Tool.

16 The PP Admin tool is launched, allowing you to do the following:

a. Install a new license key.

b. Use the Upgrade Tool to import prior configuration files and apply an existing license key.

c. Start making changes to your PP installation.

You can find more information on how to install a license in the following section.

Note   To configure and customize the Planning Portal later, the Administration Tool can be 
found at Start > All Programs > QAD > Planning Portal > Planning Portal Admin Tool.

17 After applying the license key or running the Upgrade Tool, and closing the PP Admin Tool, 
the PP Release Notes file will open in your browser. The Installer will show the following 
screen indicating that the installation is now complete.
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Planning Portal License

To begin using the Planning Portal, you must do one of the following:

1 Create a random serial number which QAD will use to create a license key for you.

2 Run the Upgrade Tool which will copy the existing license key as well as import saved 
configuration files.

Note   If the upgrade is on a new server, you will need a new license key as in Step 1 above.

To generate your serial number:

1 The PP Admin Tool may already be open from step 15 above. If not, go to go to Start > All 
Programs > QAD > Planning Portal Admin Tool.

The PP Admin Tool displays.

2 In the Planning Portal Manager in the left-hand pane, go to Security and click “License 
Generator”.
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3 Click Generate to generate a random serial number.

Note   The PP Admin tool takes some time to generate a serial number so wait a few seconds 
until a new serial number is generated (make sure the first few numbers change) before you 
copy the serial number and send the code to support@qad.com.

4 You must contact QAD, Inc. for a license key. Click Copy to copy the serial number to your 
clipboard and send the serial number to support@qad.com.

When you receive the license key from QAD, Inc., repeat Steps 1 and 2 and paste your license 
key in the License field.

5 Go to File > Save to save your serial number.

6 Close the Admin Tool.

Note   If for whatever reason the license for the PP becomes invalid when trying to save a new 
one you will need to generate a new random serial number.

Note   The PP license is tied to the specific hardware configuration when the serial number 
was generated; if there are any significant hardware changes the PP license needs to be 
replaced. This applies to any type of virtual environment as well.

Upgrade from an Earlier Version

After uninstalling the earlier version, see “Installing the Planning Portal” on page 8 to install the 
new version of the Planning Portal.

You will be able to update configuration files from an earlier Planning Portal installation if the 
prior Planning Portal was Version 5.5 or higher. In order to upgrade your settings you need to save 
the following files to another location before re-installing. 

Note   The directories below are the default locations:

C:\Inetpub\wwwroot\PlanningPortal\web.config

C:\Inetpub\wwwroot\PlanningPortal\CustomSettings\CustomSettings.xml 
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Follow the steps below to import saved configuration files into your new Planning Portal 
installation:

1 Open the Planning Portal Admin Tool and log in using the fxadmin account.

2 Select Tools > Upgrade Tool to launch the upgrade tool.

3 Locate each of the saved files (Web.config and CustomSettings.xml) with each Browse 
button.

4 Click the Upgrade button.

5 Click Save.

Note   After upgrading your configuration files with the above process your license for the 
Planning Portal will also be replaced. If your configuration files were installed in the same 
server (with the same hardware configuration) your license will work correctly. If you took the 
configuration files from a different server you will need to install a new license after following 
the process mentioned above. See Section 6-4: “Planning Portal License” on page 16.

Note   Do not use Save button of the Portal Admin Tool. Doing so will overwrite the upgrade.

Miscellaneous Configuration & Troubleshooting

The sections below detail additional configuration for successfully installing the Planning Portal. 
Some concern the Server where PP is installed and others the Internet Explorer configuration of 
the client machines. In order to successfully run and login to the PP you will need to check the all 
the sections below.

Some items are optional settings, such as Section 8.3: “Write Access to the Planning Portal’s 
Physical Directory (Required)” on page 20, which describes how to configure Windows 
authentication. Each section will be marked either required or optional.

Most common problems when accessing the Portal are related to missing configuration from this 
section. When troubleshooting problems with the Planning Portal the section below will resolve 
most issues you will encounter.
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Using .NET 2.0 (Required)

Ensure the Planning Portal is using .NET 2.0.

1 Open Internet Information Services.

2 Right-click on the Planning Portal virtual directory or the virtual directory that is used by the 
Planning Portal.

3 Click on “ASP.NET”.

4 Verify that .NET 2.0 version is selected. If not, select Version 2.0 from the drop-down.

Registering .NET Framework (Optional)

If you installed .NET Framework 2.0 while IIS was not installed you will need to re-register the 
.NET Framework on IIS. You can do so with the following steps:

For a 32-bit version operating system:

Go to the DOS prompt and change the directory to:
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

Run the following command:
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis -i

For a 64-bit version operating system:

Go to the DOS prompt and change the directory to:
C:\Windows\Microsoft.NET\Framework64\v2.0.50727\

Run the following command:
C:\Windows\Microsoft.NET\Framework64\v2.0.50727\>aspnet_regiis -i

Note   The path is based on the drive where the operating system is installed.
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Write Access to the Planning Portal’s Physical Directory (Required)

To enable Write access, you must select the Write permission to the Network Service account in the 
security properties of Planning Portal's physical directory.

1 Go to Planning Portal > PP Installation > App.

2 Right-click on “PPsetup.exe” and select “Properties”.

The PPSetup.exe Properties window displays.

3 Select the user you want to grant write access and click on the Allow checkbox.

4 Click Apply and then click OK.

Setting Up Integrated Windows Authentication (Optional)

The Planning Portal is designed to authenticate users either with Planning Portal Authentication or 
with Windows Integrated Authentication. The Windows Integrated Authentication feature depends 
on a similar setting of Internet Information Services.

To enable Windows Integrated Authentication:

1 Open Internet Information Services (IIS) Manager.

Start > My Computer > C:drive > Windows > IIS Manager.

2 Right-click the Planning Portal virtual directory and select “Properties”.
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The Planning Portal Properties window displays.

3 Select the Directory Security tab and click the Edit button in the “Authentication and access 
control” area.

The Authentication Method window displays.

4 Uncheck the “Enable anonymous access” checkbox and check the “Integrated Windows 
Authentication” checkbox.

5 Click OK and close the window.
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Excel Primary Interop Assembly (PIA) (Required)

The Excel Primary Interop Assembly (PIA) is a required DLL that enables the Planning Portal to 
send data and charts to Microsoft Excel. The PIA must be installed on the Web Server if you want 
to export data to Excel in the Classic View.

The primary interop assembly is not installed when performing a default installation of Microsoft 
Office; a custom installation is required to install it. Below is an example on how to enable this 
component while installing Microsoft Excel 2003, a similar procedure should be followed when 
installing Office 2007 or Office 2010. You should install the PIA component that matches the 
version of Excel installed in the server where the Planning Portal is installed.

1 Start the Microsoft Office Install Wizard and click through the default selections until you 
reach the Type of Installation window dialog step.

2 Select “Custom Install” and click Next.
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The Custom Setup window displays.

3 Select “Choose advanced customization of applications” and click Next.

The Advanced Customization window displays.

4 Expand the Microsoft Office Excel sub-tree and include .NET Programmability Support as a 
component to be installed.
                                                 



24     Installation Guide — QAD Planning Portal
5 Click Next.

6 Click Install in the next window and proceed with the default settings installation.

Enable the Planning Portal to Launch Microsoft Excel on the Server 
(Optional)

Note   This procedure only applies to Windows Server 2003 installations that include Windows 
Server 2003 Service Pack 1.

1 Go to Control Panel > Administrative Tools > Component Services.

The Component Services window displays.

2 Browse to Component Services > Computers > My Computer > DCOM Config.
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3 Click on “DCOM Config”.

4 Scroll down until you find the “Microsoft Excel Application” node.

5 Right-click the Excel node and click “Properties”.

6 Select the Security tab and select the “Customize” option under Configuration Permissions.

7 Click the Edit button.
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8 In the Change Configuration Permission window, add the following two accounts: ASPNET 
and Network Service (or the account under which the Default Application pool is running) 
and grant it “Full Control” permissions; this applies for Windows XP and Windows 2003 
Server. For Windows 7 or Windows 2008 Server you must add the local Everyone account and 
give it Full Control.

9 Click OK to save the permission changes and exit.

10 Select the Security tab and select the “Customize” option under “Launch and Activation 
Permissions” and “Access Permissions” section.
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11 In the Launch Permission window, add the following two accounts: ASPNET and Network 
Service (Or the account under which the Default Application pool is running under) and check 
the “Local Launch” and “Local Activation” permissions under the Allow column.

Internet Explorer Security Settings (Required)

Depending on how you access the PP you will need to make sure you have the correct security 
settings on your browser. If you are using the PP inside an Intranet you should configure the 
“Local Intranet” zone. If you are using the PP through the internet then you should configure the 
Internet zone.
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In case you still have issue working with the planning portal you should configure all three zones 
(Internet, Local Intranet and Trusted Sites) with the configuration shown below:

1 Open Internet Explorer and go to Tools > Internet Options.

2 Go to the Security tab; once there select the zone you wish to configure and click the Custom 
Level button.
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3 Once you are in the security settings page you will need to make sure all the settings are set 
exactly as the screenshot below:

4 Click OK on the Security Settings window.

5 Click OK on the Internet Options window.

6 Close Internet Explorer completely and re-open it before trying to log into the PP.

IIS, ASP.NET and .NET 3.5 Components (Required)

These components need to be installed in Windows 7 or Windows Server 2008 or later.
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Go to Control Panel ->Programs and Features -> Turn Windows features on or off.

Internet Information Services

Note   For these settings on Windows Server 2008, see “.NET Framework 3.0 and IIS 
Components (Required)” on page 33.

1 Under Web Management Tools, select the following options:

• IIS Management Console

• IIS Management Scripts and Tools

• IIS Management Service

2 In the World Wide Web Services, under Application Development Features, select 
“ASP.NET” (this will select automatically other options).

3 Under Common HTTP Features, select “Static Content”.
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4 Under Security, select “Windows Authentication”.
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Microsoft.NET Framework 3.5.1

1 Select option Windows Communication Foundation HTTP Activation.

Compatibility Mode (Required)

 In order for any client to correctly render the Planning Portal, Internet Explorer must run 
compatibility mode when logging into the Planning Portal. For more Information, see 
http://support.microsoft.com/kb/956197.
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This option is available here:

1 Open Internet Explorer.

2 In the main Menu, select Tools, and then Compatibility View Settings.

3 Add the Planning Portal’s site to the Compatibility View list.

.NET Framework 3.0 and IIS Components (Required)

Under Windows Server 2008 and higher you will need to make sure the below components are 
checked for the .NET Framework 3.0:
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Go to Control Panel -> Administrative Tools -> Server Manager -> Features -> Add 
Features.NET Framework 3.0 Features.

.Net Framework 3.0 Features

1 Select the WCF Activation option.

2 Click Add Required Role Services.

3 Click Next -> Next.

Web Server

1 Click the Role Services option at the right.

2 Under Common HTTP Features, select the following options:

• Static Content

• Default Document

• Directory Browsing

• HTTP Errors

3 Under Application Development:, select “ASP.NET” (this will select automatically other 
options).

4 Select “Add Required Role Services”.
                                          



Installation      35
5 Under Security, select “Windows Authentication”.

6 Under Management Tools, select the following options:

• IIS Management Console

• IIS Management Scripts and Tools

• Management Service

7 Click Next -> Install.

Authentication Settings

Edit the Anonymous Authentication name and make sure the user identity is not set to “Guest”. It 
should use the IUSR account or a system admin:
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Enable Web Garden in Planning Portal

Introduction

To improve availability for a Web site or application, you can increase the number of worker 
processes servicing the application pool by implementing a Web garden, an application pool that 
uses more than one worker process on a single computer. This might be helpful if you have already 
configured a single-application application pool and need to improve availability.

This document shows how to configure the web garden in two parts.

1 Set the maximum number of worker process.

2 Set the session state.

a. Session state using SQL Server

b. Session state using a State Server

Set the Maximum Number of Worker Process

In order to enabled the web garden we need to change the parameter maximum number of worker 
process with a value higher than “1”.

1 Open IIS manager.

a. Open Control Panel > Administrative Tools.

b. Double-click “Internet Information Services (IIS) Manager”.

2 Go to “Application Pools”.

a. Expand the server.

b. Select “Application Pools”.

3 Select the pool to configure and right-click (DefaultAppPool).

4 Select “Advance Settings…”.

5 Under Process Model, set the “Maximum Worker Processes” field (i.e. 3, 5, 10).

6 Click OK.

7 Restart the Pool.

a. Right-click on the process;

b. Select Stop;

c. Right-click on the process;

d. Select Start.
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Session State Configuration

Out-of-process session state mode preserves session state data by running in a worker process 
outside the worker processes where ASP.NET applications are running. One type of out-of-process 
session state uses a SQL server to store session state data. The advantage of this configuration is 
that session state is preserved despite recycling of the application's worker process, or if either the 
Windows state service or the Web server goes down.

Configure a SQL Server to Maintain Session State

When a SQL server runs on the same Web server that has the applications for which it maintains 
state, it supports a Web garden configuration, which increases the Web server's scalability. When 
the SQL server runs on another server, it supports a Web farm configuration, which greatly 
increases scalability across a group of servers.

1 Open command prompt with administrative rights.

a. Optional: If VS command prompt is installed, you can use Visual Studio 20XX command 
prompt.

2 Localize the apsnet_regsql command.

a. This command is located where the Microsoft framework 2.0 is installed.

3 Run the following command:

a. aspnet_regsql.exe -S localhost -U sa -P 2pass2 -d ASPState -ssadd -sstype c
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b. You may need to change –user (-U) and –pwd (-P) for login credentials.

c. This will create a database called ASPState that you will use in Step 7.

4 Open IIS Manager and navigate to the level you want to manage. For information about 
opening IIS Manager, see Open IIS Manager (IIS 7). For information about navigating to 
locations in the UI, see Navigation in IIS Manager (IIS 7).

5 In Features View, double-click “Session State”.

6 On the Session State page, in the Session State Mode Settings area, click “SQL Server”.

7 Type a connection string in the Connection string text box, or click Create to create a 
connection string.

8 Enter a time-out value in the Time-out text box.

9 Check the Enable Custom Database check box to use a custom database for storing session 
state data.

10 (Optional) Check the Use hosting identity for impersonation check box to use Windows 
authentication and the host process identity (either ASP.NET or a Windows service identity) 
for remote connections to the SQL database.

11 Click Apply in the Actions pane.

12 The modify session state should appear as follows in the web config.

<sessionState 

            mode="SQLServer"

sqlConnectionString="data source=127.0.0.1;user id=<username>;password=
<strongpassword>"

            cookieless="false" 

            timeout="20" 

    /
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Login to SQL Server State Database

By default, IIS uses the pool identity as the account to login to the ASPState database when the 
connection string is windows authentication. For this case we need to create the login into SQL 
Server.

1 Open SQL Management Studio.

2 Go to Security.

3 Expand Login.

4 Right-click and Select New Login…

5 Type the following: account IIS APPPOOL\DefaultAppPool. 

The “DefaultAppPool” could change if you have a different pool.

6 Set “ASPState” as the default database.

7 Select User Mapping and check the “ASPState with dbowner role”.
                                                 



40     Installation Guide — QAD Planning Portal
8 Click OK.

Configure a State Server to Maintain Session State

You can perform this procedure by using the user interface (UI), by running Appcmd.exe 
commands in a command-line window, by editing configuration files directly, or by writing WMI 
scripts.

1 Open IIS Manager and navigate to the level you want to manage. For information about 
opening IIS Manager, see Open IIS Manager (IIS 7). For information about navigating to 
locations in the UI, see Navigation in IIS Manager (IIS 7).

2 In Features View, double-click Session State.

3 On the Session State page, in the Session State Mode Settings area, click “State Server”.

4 Type a connection string in the Connection String text box, or click Create to create a 
connection string.

5 Type a time-out value in the Time-out (in seconds) text box. The default time-out value is 10 
seconds. Change to the recommended time-out which is 60 seconds.

6 (Optional) Configure cookie settings in the Cookie Settings area on the Session State page.

7 (Optional) Select the Use hosting identity for impersonation check box to use Windows 
authentication and the host process identity (either ASP.NET or a Windows service identity) 
for connections to the database.

8 Click Apply in the Actions pane.
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9 Go to Services Manager under Administrative Tools.

10 Enable the ASP .NET State Service.
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